MeteoExplorer 1.3

用户手册

 

20137


 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

© 2013, EastModelSoft Laboratory. All rights reserved


 

目录

1              MeteoExplorer简介... 1

1.1             MeteoExplorer简介... 1

1.2             MeteoExplorer主要功能... 1

1.3             MeteoExplorer产品技术特色... 1

1.4             网上资源... 5

2              系统需求与安装配置... 7

2.1             系统需求... 7

2.2             安装MeteoExplorer. 7

2.2.1         下载... 7

2.2.2         Windows下安装MeteoExplorer. 7

2.2.3         Linux下安装MeteoExplorer. 11

2.3             增加资源文件... 12

2.3.1         综合图菜单配置... 12

2.3.2         自定义云图调色板... 12

2.4             卸载MeteoExplorer. 13

2.4.1         Windows下卸载MeteoExplorer. 13

2.4.2         Linux下在卸载MeteoExplorer. 13

3              MeteoExplorer基本操作... 15

3.1             主窗口界面... 15

3.2             菜单... 16

3.2.1         文件菜单... 16

3.2.2         编辑菜单... 17

3.2.3         选项菜单... 17

3.2.4         视图菜单... 17

3.2.5         工具菜单... 18

3.2.6         帮助菜单... 18

3.3             工具条... 18

3.4             图形显示主窗口... 19

3.4.1         底图缩放与漫游... 19

3.4.2         缩放地图以适合指定的区域... 21

3.4.3         全屏显示... 22

3.5             图层管理... 22

3.5.1         图层及其组织方式... 22

3.5.2         基本图层管理功能... 24

3.5.3         图层的漫游与动画... 25

3.6             缩略图(邮票图)显示... 26

3.7             状态栏... 27

3.8             用户偏好设置... 27

3.8.1         切换图形渲染模式... 28

3.8.2         根据地图比例尺的大小动态调整屏幕显示内容... 28

3.8.3         绘制曲线预览功能... 31

3.8.4         中英文用户界面语言快速切换... 33

4              地图与地理信息功能... 35

4.1             地图投影参数的设置... 35

4.2             基本地图功能... 37

4.2.1         主题风格... 37

4.2.2         地形显示... 39

4.2.3         单省显示与省份填色... 39

4.2.4         在省界内显示所有图形... 41

4.2.5         显示南海... 42

5              页面布局及其设置... 45

5.1             页面布局设计... 45

5.2             选择页面布局模式... 46

5.3             从图层信息中获取标题和图例... 47

5.4             布局设置... 49

5.4.1         预览区... 49

5.4.2         设置标题... 49

5.4.3         设置画布... 51

5.4.4         设置图例... 52

6              通用模式数据的分析与显示... 55

6.1             WMO GRIB1/GRIB2数据的分析与显示... 55

6.1.1         通用模式数据选项对话框... 56

6.1.2         物理量场的等值线分析... 58

6.1.3         风场的流线分析... 63

6.1.4         导出分析场数据到磁盘文件... 66

6.2             NetCDF数据的分析与显示... 66

6.3             GrADS数据的分析与显示... 68

7              地面观测数据的分析与显示... 69

7.1             地面天气要素的显示设置... 69

7.2             地面天气要素的客观分析... 71

8              高空观测数据的分析与显示... 79

8.1             高空填图数据中天气要素的显示设置... 79

8.2             高空填图天气要素的客观分析... 80

9              地面单要素站点观测的分析与显示... 85

9.1             天气要素的显示设置... 85

9.2             天气要素的客观分析... 87

10            格点数据的分析与显示... 91

10.1          等值线分析范围的设置... 92

10.2          等值线分析值的设置... 94

10.3          等值线显示属性设置... 95

10.3.1       等值线填色... 96

10.4          显示格点场中格点上的数据... 99

11            探空数据的分析与显示... 101

11.1          探空分析窗口界面... 101

11.1.1       工具栏... 102

11.1.2       要素显隐选择与属性设置子窗口... 103

11.1.3       探空数据显示子窗口... 106

11.1.4       风矢显示子窗口... 106

11.1.5       物理量数值列表显示子窗口... 107

11.2          物理量指数计算列表... 107

12            台风路径数据的显示... 111

12.1          台风路径显示属性的设置... 111

13            城市预报数据的显示... 113

13.1          城市预报天气要素显示属性设置... 113

14            流线数据的分析与显示... 115

14.1          流线数据的显示设置... 115

14.2          风场衍生物理量的计算及其等值线分析... 118

15            天气图交互制作... 121

15.1          认识天气图制作工具箱... 121

15.2          使用天气图制作工具箱... 123

15.2.1       单点型天气符号及其绘制方法... 123

15.2.2       矢量型天气符号及其绘制方法... 124

15.2.3       多态单点型天气符号及其绘制方法... 124

15.2.4       曲线型天气符号及其绘制方法... 125

15.2.5       曲线型天气符号的修改... 126

15.2.6       天气符号的移动与剪切... 129

15.3          绘图操作命令的撤销与恢复... 130

15.4          天气图的(自动)保存... 130

16            中尺度天气分析... 133

16.1          认识中尺度工具箱... 133

16.2          使用中尺度工具箱... 134

16.2.1       单点型天气符号及其绘制方法... 134

16.2.2       矢量型天气符号及其绘制方法... 135

16.2.3       曲线型天气符号及其绘制方法... 135

16.2.4       其它天气符号... 135

16.3          操作命令的管理与编辑图层的自动保存... 135

17            卫星云图、雷达数据的显示... 137

17.1          卫星云图的显示和调色板的使用... 137

17.2          雷达数据的显示... 139

17.3          高分辨率多通道云图的显示和调色板设置... 140

17.4          自定义云图调色板... 142

17.5          云图动画... 142

18            剖面图的制作... 145

18.1          剖面图制作的准备工作... 145

18.1.1       剖面图工具栏简介... 145

18.1.2       指定剖面图的数据源文件... 146

18.1.3       绘制剖面的空间位置... 147

18.2          剖面图的生成及显示属性设置... 149

18.2.1       生成剖面图... 149

18.2.2       剖面图的显示属性设置... 149

18.2.3       剖面图铅直方向上显示范围的修改... 151

19            非常规数据的显示... 153

19.1          邮票图的显示... 153

19.2          L波段探空数据的分析与显示... 154

20            图像保存与出图支持... 157

20.1          保存为图像文件... 157

20.2          保存为矢量图文件... 157

20.3          复制到系统剪贴板... 157

21            地理信息系统功能... 159

21.1          ESRI shapefile数据的解析与显示... 159

 

 


第1章     MeteoExplorer简介

1.1     MeteoExplorer简介

MeteoExplorer是一款跨平台的气象数据分析,显示软件。MeteoExplorer支持常用的气象数据格式,包括NetCDFGRIB1GRIB2GrADS、和MICAPS部分数据格式。同时具备基本的地理信息系统(GIS)功能。MeteoExplorer使用C++语言开发,具有原生程序所特有的速度快、系统资源需求低的优点。MeteoExplorer从设计之初考虑跨平台支持,目前支持Microsoft WindowsLinux、和SGI Irix操作系统。

1.2     MeteoExplorer主要功能

MeteoExplorer的主要功能有:

l  图层管理功能(图层翻页与动画);

l  地面、探空观测场的客观分析;

l  格点场的等值线分析和填色;

l  风场的流线分析;

l  常用的物理量计算;

l  NetCDF资料显示功能;

l  GRIB1/GRIB2资料显示功能;

l  GrADS资料显示功能;

l  MICAPS 基本数据显示功能;

l  卫星云图资料(AWX格式、GPF格式、HDF格式)显示和动画功能;

l  天气图交互制作(操作撤销与恢复,自动保存);

l  中尺度天气分析功能;

l  剖面图制作功能;

l  地图缩放、漫游和投影切换;

l  全屏显示和区域缩放功能;

l  页面布局功能;

l  缩略图(邮票图)显示功能;

l  图像保存功能,格式为BMPJPGPNG

l  矢量图形EMF格式输出功能(只适用于Windows版本);

l  系统配置功能(动态菜单);

l  中英文用户界面语言快速切换功能。

其中中尺度天气分析和剖面图制作是MeteoExplorer 1.2版本中新增加的功能。页面布局是1.3版本中新增加的功能。

1.3     MeteoExplorer产品技术特色

与目前已有的地理信息科学及气象科学软件相比,MeteoExplorer具有如下五大技术特色:

 

一,跨平台支持

 

MeteoExplorer的最初设计目标就是能够在主流的计算平台上运行,而且是以原生(native)方式运行,而不是借助虚拟机或者牺牲程序性能的解释运行环境(如JAVE.NET等)。我们希望您能在您喜爱的计算平台上使用MeteoExplorer完成您的工作。目前MeteoExplorer支持Windows XP/Vista/7/8Redhat Enterprise Linux 5/6,和SGI Irix操作系统。图11显示了MeteoExplorer运行在Windows XPA)、Windows VistaB)、Redhat Enterprise Linux 5 C)、和SGI IrixD)下的屏幕截图。

(A) Windows XP

(B) Windows Vista

(C) Redhat Enterprise Linux 5

(D) SGI Irix 6.5

11MeteoExplorer支持Windows XP/Vista/7/8Redhat Enterprise Linux 5/6,和SGI Irix操作系统。

 

二,注重程序运行效率和用户体验

 

MeteoExplorer从最初设计开始强调程序运行性能,以提供用户工作效率,因此,我们没有选择解释类型的程序设计语言(如JAVAC#),而是使用C++这样的原生语言进行开发。因此,MeteoExplorer具有系统资源要求低、程序启动速度快的特点。此外,MeteoExplorer使用Direct3D硬件加速渲染技术(Unix/Linux版本中使用OpenGL),以提供较快的图形图像显示速度,从而保证流畅的用户体验。更为重要的是MeteoExplorer不但在主窗口中使用硬件加速渲染,而且在辅助窗口(如剖面图、探空窗口)中同样使用硬件加速渲染。

 

三,所见即所得的矢量图形输出

 

随着气象科学技术的迅速发展,科研业务工作人员对气象软件的图形显示速度和效率提出了更高的要求,要求能够在尽可能短的时间内完成大量数据的分析和可视化功能。同时要求能够将所显示的图形保存成矢量格式的图形文件,便于将业务产品或者研究成果进行演示和发表。

针对上述需求,MeteoExplorer中设计并实现了一种新型的集多种图形渲染技术为一体的图形渲染引擎,它既能够提供硬件图形加速渲染技术所享有的速度和效率,又能够提供软件图形渲染技术所特有的矢量图形输出功能。图12显示了将图11B中窗口显示的图形复制并粘贴到Microsoft Word程序中的屏幕截图。图20‑1(第156页)显示了将图11B中窗口显示的图形复制并粘贴到Microsoft PowerPoint程序中的屏幕截图。

屏幕截图图像的保存格式为Windows增强型元文件格式(Enhanced Meta Format, EMF),这是一种不受图像缩放而导致质量受损的图像格式,也是撰写科技文章所要求的一种格式。

 

12MeteoExplorerWindows版本支持将程序窗口中显示的图形内容复制到系统剪贴板中,供外部程序直接使用。本图是将剪贴板中的内容粘贴到Microsoft Word程序中。

 

 

四,先进的客观分析技术

 

MeteoExplorer中集成了较为先进的客观分析方法。特别是高空探空资料的客观分析结果能够达到天气图分析业务运行的标准。图13给出了201232308500hPa位势高度场的客观分析结果。由图可见,MeteoExplorer的客观分析等值线不仅很好地与观测数据相吻合,而且其光滑美观程度能够与预报员手工分析绘制的等值线相媲美。

 

13201232308500hPa位势高度场的客观分析结果。

 

五,全面的数据格式支持

 

MeteoExplorer 最主要的功能就是分析、显示常用的气象数据。目前MeteoExplorer 能够支持的数据格式有WMO GRIB1/GRIB2NetCDFGrADS、和MICAPS常用数据类型。

 

14MeteoExplorer支持WMO GRIB1/GRIB2NetCDF的数据格式。这里显示了对WMO GRIB2格式的NCEP全球预报系统预报数据资料的分析结果。

 

我们希望通过对国际上主流气象数据格式(如WMO GRIB1/GRIB2NetCDFGrADS等)的支持,能够提高国内用户的工作效率,减少她们编程处理资料的时间,把精力放到理论研究中。众所周知,国际上已经有诸多知名的气象软件如NCLVis5DIDVGrADS等等。然而,这些软件虽然技术领先、功能强大,但由于存在着一些不足之处,导致它们并没有满足国内所有用户的要求。具体来说,这些软件都是基于UNIX操作系统,以命令行操作为主要工作方式,对WordPowerPoint等字处理软件支持有限。而国内气象工作者通常使用Windows操作系统,以用户图形界面为主要工作方式。因此国际上的气象软件存在安装困难,使用方式不习惯,配套软件少等问题。

MeteoExplorer不仅能够读取资料中的物理量数据,而且能够在已有物理量数据的基础上,计算一些衍生物理量。详细的功能介绍请参考6(第53页)。图14显示了MeteoExplorer读取WMO GRIB2格式的NCEP全球预报系统预报数据资料的分析结果。图中显示了500hPa位势高度场(绿色等值线)和1.5个位势涡度单位面上的位势高度场(填色)。

1.4     网上资源

您可以访问互联网地址www.eastmodelsoft.com/software/mexplorer_cn.htm来获取更多帮助,包括最新版本的程序下载,帮助文档,电子邮件答疑等。


第2章     系统需求与安装配置

2.1     系统需求

支持的操作系统

l  Microsoft Windows XP/Vista/7/8

l  Red Hat Enterprise Linux (RHEL) 5/6

l  SGI Irix 6.5

 

中央处理器

PC机:最低Intel奔腾2.4GHz;推荐Intel 酷睿双核1.5GHz

SGI工作站:MIPS R16000A 800MHz

 

图形适配器

OpenGL渲染模式下要求显卡最低支持OpenGL1.2

Direct3D渲染模式下要求显卡最低支持DirectX 9

显示器分辨率至少为1024×768像素。

2.2     安装MeteoExplorer

2.2.1    下载

您可以访问www.eastmodelsoft.com/downloads.htm下载MeteoExplorer的最新发行版本。

2.2.2    Windows下安装MeteoExplorer

由于Windows操作系统中提供的Windows 32-bit on Windows 64-bitWoW64)技术以保证32位程序在64Windows操作系统下能够正常运行,所以您不必担心您的系统是32位还是64位。MeteoExplorer32位和64位的Windows操作系统中都能正常运行。

您需要下载mesetup-1.3.nnnn.zip或者mefiles-1.3.nnnn.zip这两个文件,其中nnnn的程序编译号,其数值会经常变换,越大表示程序的版本越新。前者是安装文件,适合普通用户使用;后者是包含MeteoExplorer所有程序文件的压缩文件,将其解压后即可直接使用,无需安装,因此MeteoExplorer实际上是一款绿色软件。如果您使用安装文件,请将文件解压到任意目录下。它包括mesetup.exeMeSetup.msi两个文件和vcredist_x86文件夹。

首先运行mesetup.exe,出现欢迎画面(21)。

21: MeteoExplorer安装欢迎画面。

 

点击“Next”按钮进入安装目录选择画面( 22)。

22MeteoExplorer安装目录选择画面。

 

这里,您可以改变MeteoExplorer的安装目录。此外,您还可以决定是否把MeteoExplorer的菜单组和桌面快捷方式安装到所有帐户的目录下。选择“Everyone”将MeteoExplorer的菜单组和桌面快捷方式安装到所有帐户的目录下;选择“Just meMeteoExplorer的菜单组和桌面快捷方式安装到当前登录帐户的目录下。点击“Next”按钮进入安装确认画面( 23)。

 

23MeteoExplorer安装确认画面。

 

点击“Next”按钮开始安装过程。如果您要取消安装,请点击“Cancel”按钮。您还可以点击“Back”按钮返回到上一步以修改前面的设置。

24MeteoExplorer安装过程画面。

 

24显示了MeteoExplorer安装过程的画面,由于MeteoExplorer不依赖第三方框架库(如.NETJRE等),因此安装过程很快。安装结束后是安装完成的画面( 25)。

25MeteoExplorer安装完成画面。

 

安装完成后,你的桌面和开始菜单中将会出现MeteoExplorer的桌面快捷方式和菜单组。

2.2.3    Linux下安装MeteoExplorer

Windows不同,Linux操作系统下没有提供类似WOW64的兼容机制,而且32位函数库和64位函数库分开存放。因此您首先需要确定您的Linux操作系统是32位还是64位。一种方法是运行uname命令。

$ uname -a

参数’a’表示输出所有信息。如何输出信息中含有i686,i386字样,那么您的系统是32位的;如何输出信息中含有x86_64字样,那么您的系统是64位的。

对于32为系统,您需要下载install.shmeinstaller-1.0.nnnn-i386.tar.gz两个文件;对于64为系统,您需要下载install.shmeinstaller-1.0.nnnn-x86_64.tar.gz两个文件。下载后请将这两个文件放到同一文件夹下面,然后以root用户执行安装脚本install.sh

$ chmod +x install.sh

$ su

# ./install.sh /opt

Remove old files …

Copy installation files to /var/mexplorer

Done.

默认情况下MeteoExplorer被安装到/usr/local目录下面。如果您需要改变安装目录,可以在安装脚本install.sh接一个参数来制定新的安装目录。例如上面的例子中MeteoExplorer将被安装在/opt目录下。

2.3     增加资源文件

MeteoExplorer支持MICAPS中的资源文件,包括综合图菜单配置文件,云图调色板文件等。但为了避免版权纠纷,在MeteoExplorer发行版本中不能分发这些文件。如果您需要在MeteoExplorer中显示综合图菜单,或者使用云图调色板,请自行编辑这些资源文件并将其放到MeteoExplorer的安装文件夹中(Windows版本缺省安装位置是C:\Program Files\EastModelSoft\Meteo ExplorerUnix/Linux版本缺省安装位置/usr/local/mexplorer/bin)。

2.3.1    综合图菜单配置

综合图菜单配置文件的格式请参考20.3附录A。文件写好后,请将其命名为micapsDataMenu.txt,然后放到MeteoExplorer的安装文件夹中。

         MeteoExplorer默认不显示综合图数据菜单。用户可以通过菜单项“OptionShow Data Menu”来显示/隐藏综合图数据菜单。

26Meteo Explorer支持用户自定义数据菜单。

 

2.3.2    自定义云图调色板

MeteoExplorer支持用户自定义云图调色板。Meteo Explorer将调色板分为四类,分别对应四类图像:红外图像(I)、雷达回波图像(R)、可见光图像(V)、和水汽图像(W)。每类可以使用最多10个调色板(序号00-09)。例如,雷达回波图像的第三个调色板的名称是R-02(请注意序号从0开始)。MeteoExplorer对每一类提供了两种调色板:一种是彩色调色板00,一种是黑白灰度调色板01-09。用户可以覆盖01-09号调色板以使用自己定制的调色板。调色板的格式见附录B。例如,如果用户想替换雷达回波图像的第三个调色板,那么请自己编辑好符合调色板格式的文本文件,并命名为R-02.rgb,把这个文件放到MeteoExplorer的安装文件夹中。

2.4     卸载MeteoExplorer

2.4.1    Windows下卸载MeteoExplorer

Windows操作系统下卸载MeteoExplorer,请使用“控制面板”中的“卸载程序”(图27),找到“Meteo Explorer”,点击“卸载”按钮即可将MeteoExplorer从系统中删除。

 

27: Windows操作系统下卸载MeteoExplorer,请使用“控制面板”中的“卸载程序”。

 

2.4.2    Linux下在卸载MeteoExplorer

Linux下在卸载MeteoExplorer,直接删除安装文件所在目录即可。例如,MeteoExplorer被安装在/usr/local/mexplorer目录中,执行下面命令语句:

$ cd /usr/local

$ su

# rm –rf mexplorer

 

注意执行上面最后一条命令需要root管理员权限。

 

 


第3章     MeteoExplorer基本操作

3.1     主窗口界面

启动MeteoExplorer后,主窗口界面如 31Windows版本)和 32Unix/Linux版本)所示。

31MeteoExplorer Windows版本的主窗口界面。

 

MeteoExplorer遵循标准桌面程序界面布局,包括标题栏、菜单条、工具条、图形显示主窗口、图层显示设置窗口、状态栏。MeteoExplorerUnix/Linux版本( 32)采用了与Windows版本不同风格的界面元素,目的是使MeteoExplorer与操作系统整体界面风格更为一致。但是两个版本的布局是一样的。

32MeteoExplorer Linux版本的主窗口界面。

 

3.2     菜单

菜单提供了所有功能的访问方式。下面按照顶级菜单的分类分别介绍各个菜单项实现的功能。

3.2.1    文件菜单

31列出了文件菜单中各个菜单项提供的功能。

 

31:文件菜单中各个菜单项提供的功能。

菜单项

功能

快捷键

新建

创建一个新的交互图层。参考15

Ctrl+N

打开

打开一个数据文件。

Ctrl+O

保存

将当前的交互图层保存为MICAPS14类数据文件。

Ctrl+S

另存为

将当前的交互图层以另一个名称保存为MICAPS14类数据文件。

Ctrl+A

保存为图片

将主窗口的显示内容保存为图像文件。图像格式有BMPJPGPNG。参考20

保存为矢量图

将主窗口的显示内容保存为EMF格式的矢量图文件。参考20

退出

退出程序.

Ctrl+Q

 

3.2.2    编辑菜单

32列出了编辑菜单中各个菜单项提供的功能。

 

32:编辑菜单中各个菜单项提供的功能。

菜单项

功能

快捷键

撤销

撤销前一操作命令。参考15

Ctrl+Z

恢复

恢复前一操作命令。参考15

Ctrl+Y

复制

将主窗口的显示内容以EMF格式保存到系统剪贴板中。此功能只在Windows版本中提供。参考20

Ctrl+C

插入,图片

打开图像文件并将图像插入到当前的交互图层中。参考15

 

3.2.3    选项菜单

33列出了选项菜单中各个菜单项提供的功能。

 

33:选项菜单中各个菜单项提供的功能。

菜单项

功能

快捷键

偏好设置

设置通用用户选项。参考3.8节。

地图与投影

设置地图和投影选项。参考4

主窗口布局设置

主窗口布局设置。参考5

显示数据菜单

显示/隐藏数据菜单。参考2.3.1节。

 

3.2.4    视图菜单

34列出了视图菜单中各个菜单项提供的功能。

 

34:视图菜单中各个菜单项提供的功能。

菜单项

功能

快捷键

图层管理

调出图层管理窗口。参考3.5节。

缩略图显示

缩略图(邮票图)显示方式。参考3.6节。

布局,看图模式

将主窗口布局设置为看图模式。参考5.1节。

布局,出图模式

将主窗口布局设置为出图模式。参考5.1节。

翻页,前一时次

向前一时刻翻页。参考3.5节。

Alt+Left

翻页,后一时次

向后一时刻翻页。参考3.5节。

Alt+Right

翻页,下一层次

向下一层次翻页。参考3.5节。

Alt+Down

翻页,上一层次

向上一层次翻页。参考3.5节。

Alt+Up

动画

以动画方式显示选中的图层。参考3.5节。

翻页步长

设置翻页动画的时间间隔。

区域缩放

缩放地图以适合制定的区域。参考3.4.2节。

全屏显示

在全屏和窗口显示模式之间切换。参考3.4.2节。

F11

 

3.2.5    工具菜单

35列出了视图菜单中各个菜单项提供的功能。

 

35:工具菜单中各个菜单项提供的功能。

菜单项

功能

快捷键

天气尺度工具箱

打开天气图交互制作工具箱。参考15

中尺度工具箱

打开中尺度交互制作工具箱。参考16

制作剖面图

创建基于模式数据的剖面图。参考18

 

3.2.6    帮助菜单

36列出了帮助菜单中各个菜单项提供的功能。

 

36:帮助菜单中各个菜单项提供的功能。

菜单项

功能

快捷键

帮助主题

打开MeteoExplorer 帮助文档。

F1

MeteoExplorer 主页

打开www.eastmodelsoft.com网址,以获取关于MeteoExplorer的网上资源。

关于MeteoExplorer

打开关于对话框,显示MeteoExplorer版本信息。

 

3.3     工具条

工具条为用户提供执行常用命令的一种更为方便直观的方式。表37给出了MeteoExplorer工具条中按钮对应的命令。

 

37MeteoExplorer工具条中按钮对应的命令。

按钮对应的菜单项名称

Windows版本中按钮图像

Unix/Linux版本中按钮图像

功能

新建

创建一个新的交互图层。参考15

打开

打开一个数据文件。

保存

将当前的交互图层保存为MICAPS14类数据文件。

撤销

撤销前一操作命令。参考15

恢复

恢复前一操作命令。参考15

复制

 

将主窗口的显示内容以EMF格式保存到系统剪贴板中。此功能只在Windows版本中提供。参考15

将底图的大小和位置还原到初始状态。

图层管理

调出图层管理窗口。参考3.5节。

缩略图显示

缩略图(邮票图)显示方式。参考3.6节。

页面布局设置

 

设置主窗口布局,参考5

天气尺度工具箱

打开天气图交互制作工具箱。参考15

制作剖面图

 

创建基于模式数据的剖面图。参考18

翻页,前一时次

向前一时刻翻页。

翻页,后一时次

向后一时刻翻页。

翻页,下一层次

向下一层次翻页。

翻页,上一层次

向上一层次翻页。

动画

以动画方式显示选中的图层。

翻页步长

 

设置翻页和动画时相邻图层之间的时间间隔。

 

3.4     图形显示主窗口

3.4.1    底图缩放与漫游

缩放:在窗口某处双击鼠标左键或者向前滑动鼠标滚轮放大;双击鼠标右键或者向后滑动鼠标滚轮缩小。

拉窗放大:在窗口某处同时按住Ctrl键和鼠标右键,在拖动鼠标过程中会构成从起始点到当前鼠标位置点的矩形区域(33),释放鼠标右键结束拉窗放大操作。此时鼠标移动构成的矩形范围内的底图区域将被放大到整个窗口( 34)。

 

33在窗口某处同时按住Ctrl键和鼠标右键开始拉窗放大,在拖动鼠标过程中会构成从起始点到当前鼠标位置点的矩形区域(图中红色矩形)。

 

漫游:在窗口移动鼠标时,鼠标光标在窗口中的视图坐标和对应的经纬度坐标将显示在状态栏中。在窗口某处按住鼠标左键(或中键),拖动到某处后抬起,在此过程中底图将随鼠标一起移动。

还原底图至初始状态:点击工具栏中的Home按钮将底图还原到初始状态下的大小和位置。

 

34释放鼠标右键结束拉窗放大操作。此时鼠标移动构成的矩形范围内的底图区域将被放大到整个窗口。

 

3.4.2    缩放地图以适合指定的区域

将底图缩放到指定的区域范围是用户输出图像时常用的功能。MeteoExplorer支持按照指定的地理区域范围将底图充满整个窗口。要实现这一功能,请选择菜单项“View, Zoom to Area”,打开“”对话框( 35)。其中“Longitude start:end”是起始和结束经度;“Latitude start:end”表示起始和结束纬度。

 

35MeteoExplorer提供了将底图缩放到指定的区域范围的功能。

 

在例子中,用户指定将底图缩放到东经70~130度,北纬15~55度。缩放的结果如 36所示。

36:当用户指定范围为东经70~130度,北纬15~55度后底图的缩放结果。

 

提示:在MeteoExplorer中,东半球经度范围是0~180度,西半球经度范围是-180~0度;北半球纬度范围是0~90度,南半球纬度范围是-90~0度。

3.4.3    全屏显示

MeteoExplorer支持全屏显示,用户可以通过菜单项“View, Full Screen”或者快捷键F11在全屏模式和窗口模式之间切换。

3.5     图层管理

3.5.1    图层及其组织方式

MeteoExplorer中,图层是指逻辑上构成一个整体的图形物体的集合。一个图层既可以是由几个天气符号的集合,也可以是包括地面站点观测数据、等值线、天气系统(如槽线,高低压中心等)的天气图。在实际操作中,MeteoExplorer一般把一个文件中所包含的所有图形物体看作一个图层。这也是一些气象软件使用的图层管理方法。

当使用一个数据文件保存某一层次和时次下的一个要素场的信息时,这种传统的图层管理方法是非常适合的。在气象数据服务器中的文件组织方式上,通常按照数值模式、产品类型、要素、层次、创建多级文件目录,以起报时间和预报时效来命名文件。一个文件对应某一要素在给定层次和时次下的物理场。对每个图层,其常用的操作包括翻页,动画(即定时翻页)、显示、隐藏、修改、查看、删除、刷新和属性设置。表38给出了这些操作的含义。然而,当引入数值模式输出的数据文件时,传统的图层管理方式就显得不太适合了。因为一个模式数据文件往往包括多个要素、层次、和时次的数据。当前针对单个要素场的操作,如翻页、动画、修改、查看等,对于一个庞大的模式数据文件来说,已经失去了原有的意义。

为此,从MeteoExplorer 1.3版本开始,我们对图层管理功能进行了增强,使之适合多种类型的气象数据文件。在MeteoExplorer 1.2及其之前的版本中,图层管理窗口以列表的方式组织图层,每一个图层对应列表中的一行(图37)。在新的图层管理窗口中,以树状结构组织图层(38)。每个图层对应树中一个节点。树中的节点按照深度分为两类,深度为一的节点对应由数据文件创建的图层,例如由MICAPS数据文件或者模式数据文件创建的图层。深度为二的节点对应由模式数据文件中某一要素在给定层次和时次下数据创建的图层。例如在图38中,用户先后打开了三个文件:第一个是T639模式850hPa温度场;第二个是GRIB格式的NCEP数据文件,其中又从该数据中分析得到的500hPa位势高度场和温度场。第三个图层是一个交互制作得到的天气图。系统把这三个文件对应的图形看作三个图层进行管理,而又把由NCEP数据文件计算得到的两个图形看作子图层进行管理。

 

37MeteoExplorer的图层管理窗口。

 

为方便用户区分不同图层,MeteoExplorer提供了如下几个小功能:

1.       用图层所对应的等值线的颜色作为图层标题文字的颜色。当一个图层没有等值线时,其标题文字的颜色为黑色。

2.       当一个图层被隐藏时,该图层标题文字的颜色变为淡灰色。

3.       包含多个要素、层次和时次数据的数值模式文件对应的的图层用图标 表示。其他的图层用图标 表示。

4.       当前正在编辑的图层图标 表示。

5.       所有被选中的图层左侧的选择框控件处于选中状态,同时该图层的标题文字背景用灰色高亮显示。

 

38:在新的图层管理窗口中,以树状结构组织图层。深度为一的节点对应由数据文件创建的图层;深度为二的节点对应由模式数据文件中某一要素在给定层次和时次下数据创建的图层。

 

3.5.2    基本图层管理功能

38描述了MeteoExplorer中提供的图层管理功能。

 

38MeteoExplorer提供的图层管理功能。

功能按钮

功能描述

显示

显示被选中的图层。如果被选中的图层包含等值线,则等值线的颜色与该图层标题文字的颜色一致。当一个图层没有等值线时,其标题文字的颜色为黑色。

隐藏

隐藏被选中的图层,即被选中的图层不在程序主窗口中出现。该图层标题文字的颜色显示为淡灰色。

修改

将被选中的图层置于被修改状态。此时用户可以以交互的方式编辑该图层。当前正在编辑图层的标题文字的背景为灰色以高亮显示。

查看

查看被选中的图层文件的内容。MeteoExplorer会运行外部程序来打开被选中图层对应的文件。

删除

删除被选中的图层。

刷新

重新读取被选中图层对应的文件。

属性

打开图层属性对话框。用户通过图层属性对话框可以配置图形的显示属性和分析方法。用户也可以通过使用鼠标双击图层标题打开图层属性对话框。

 

以上操作的对象是被选中的图层。用户可以用鼠标左键单击图层的标题或者左侧的选择框控件以选中一个图层,用鼠标左键单击不同图层的标题以选中多个图层。被选中的图层将会高亮显示。用鼠标左键单击已被选中的图层将取消已选中的图层。此外,用户也可以通过使用鼠标双击图层标题打开图层属性对话框。

小提示:用户可以通过使用鼠标双击图层标题来打开图层属性对话框。

3.5.3    图层的漫游与动画

常见的气象数据文件的结构通常使用下面的要素来进行组织:

l  铅直方向上的层次;

l  时间序列中的不同时刻;

l  物理量元素。

一个图层往往是某一物理量元素在某一固定时刻,某一层次上的数据集合。用户通常希望从当前图层快速地转到相邻时刻,相邻层次所对应的图层。MeteoExplorer把这一功能称为图层的漫游(或称为翻页)。

要实现图层的漫游功能,首先在图层管理窗口中选中要漫游的图层,然后通过菜单(或者工具栏)中对应的菜单项(或者按钮)。表34给出了实现图层漫游功能所用到的菜单项、工具栏按钮,和快捷键的详细说明。

         除了图层的漫游之外,用户有时希望以动画的方式显示一个时间序列中的所有图层。MeteoExplorer把这一功能称为图层的动画。与图层漫游的操作方式相似,用户首先在图层管理窗口中选中要进行动画显示的图层,然后选择菜单项“View, Animation”,或者对应的工具栏按钮 Windows版本)、 Unix/Linux版本)开始动画。动画开始后,上述菜单项会变为“View, Stop”和 Windows版本)、 Unix/Linux版本)。再次选择这些菜单项或按钮以结束动画。

 

最后,表39给出了在不同类型数据文件的情况下,所有图层操作的具体含义。

 

39:在不同类型数据文件的情况下图层操作的具体含义。

     数据源

 

操作

MICAPS数据文件生成的图层(一级节点)

模式数据文件生成的图层(一级节点)

由模式数据文件计算得到的图层(二级节点)

按时次翻页/动画

读取文件所在文件夹中的下一个文件。(文件按时间命名)

读取文件所在文件夹中的下一个文件。

分析并显示当前要素在给定层次和时次情况下相邻时次的数据。

按层次翻页

读取文件所在相邻文件夹中的同名文件。(文件最内层文件夹按照层次命名)

读取文件所在相邻文件夹中的同名文件。

分析并显示当前要素在给定层次和时次情况下相邻层次的数据。

显示

显示被选中的图层。

显示被选中的图层。

显示被选中的子图层。当父图层处于隐藏状态时,子图层将不被显示。

隐藏

隐藏被选中的图层。

隐藏被选中的图层。

隐藏被选中的子图层。

修改

将被选中的图层置于被修改状态(仅当当前图层可编辑时)

无效操作

无效操作

查看

查看被选中的图层所对应文件的内容。

无效操作

无效操作

删除

删除被选中的图层

删除被选中图层,包括该图层所包含的所有子图层

删除被选中的子图层。当所有子图层都被删除后,父图层也将被删除。

刷新

重新加载被选中的图层

重新加载被选中的图层

无效操作

属性设置

设置被选中的图层的显示属性

增加/删除子图层

设置被选中的子图层的显示属性。

 

MeteoExplorer 1.3版本中,新增了设置翻页时间间隔的功能。使用方法是在视图菜单中选择“翻页步长”,或者单击工具栏中的“翻页步长”按钮,两种方法都将弹出如图39所示的菜单。

39:在视图菜单中选择“翻页步长”,或者单击工具栏中的“翻页步长”按钮,都会调出图中的菜单。

 

3.6     缩略图(邮票图)显示

缩略图显示方式为用户提供了快速预览所有图层的功能。图310显示了当用户打开六个图层文件后的缩略图显示结果。用户可以通过菜单项“View, Thumbnail View”,或者工具栏中的按钮 Windows版本)、 Unix/Linux版本)在正常显示模式和缩略图显示模式之间切换。注意到在图层管理窗口中被隐藏的图层将不显示在缩略图中。此外,通用模式数据(请参考6)中如何包含多个图层,则每一个图层将单独显示为一个缩略图。

310:当用户打开六个图层文件后的缩略图显示结果。

 

3.7     状态栏

状态栏显示鼠标光标处的屏幕坐标值和对应的经纬度坐标值。但是在全屏显示模式和缩略图(邮票图)显示模式下状态栏不显示这些信息。

3.8     用户偏好设置

MeteoExplorer提供了多种选项以便用户定制程序的行为。要设置这些用户选项,请选择菜单项“OptionPreferences”。MeteoExplorer目前提供了七个选项:

l  启用硬件加速渲染;

l  根据地图比例尺动态调整显示内容;

l  启动绘制天气图预览功能;

l  在视图中显示图层标题;

l  设置动画时间间隔;

l  设置用户界面语言为英语或简体中文;

l  设置数据源路径。

3.8.1    切换图形渲染模式

MeteoExplorer内置了创新性的多功能图形渲染引擎。程序可以在硬件加速渲染和软件渲染之间切换[1]。这样做的目的是为了满足气象预报业务和科研工作对软件系统图形显示功能所提出的越来越高的要求。首先,硬件加速渲染技术所提供的速度和效率能够使用户在更短的时间内处理海量数据,提高其工作效率。其次,软件图形渲染技术支持矢量图形输出,能够生成高质量的图像文件。第三,当显示适配器出现硬件方面的兼容性问题,或者用户远程登陆计算机时,硬件加速渲染一般不能正常工作。此时MeteoExplorer会自动切换到软件图形渲染模式下。这也是众多商业软件(如Microsoft WordInternet Explorer)的做法。

要打开硬件加速渲染模式,请在用户偏好设置对话框(图311)中选中“Render graphics with hardware acceleration”。

 

311:用户偏好设置对话框为用户提供了定制程序行为的选项。

 

3.8.2    根据地图比例尺的大小动态调整屏幕显示内容

第二个选项是根据地图比例尺的大小动态调整屏幕显示内容,此选项默认配置下打开。一些气象数据在空间的分布比较密集,这样的数据包括细网格的格点场、流场,细网格的降水场,地面填图数据,和城市预报数据等。如果全部显示文件中的所有数据则会存在如下两个问题:

第一,程序因为需要渲染太多的图形对象,造成自身运行性能的急剧下降;

第二,各个数据之间相互覆盖,造成用户根本看不清数据的内容。

针对这一问题,MeteoExplorer提出了根据地图比例尺的大小动态调整屏幕显示内容的方法,其思想是程序窗口中显示的内容数量随着地图比例尺的增大而减少。例如,图312显示了20131108时欧洲中心24小时降水预报场,注意到该图是比例尺为1000千米(如图右下角所示)时的显示结果。此时平均每2.5度显示一个站点数据。

 

312:比例尺为1000千米时欧洲中心24小时降水预报场的显示结果。此时平均每2.5度显示一个站点数据。

 

当用户放大地图到比例尺到100千米时,平均每0.5度显示一个站点数据(图313)。

313:比例尺为100千米时欧洲中心24小时降水预报场的显示结果。

 

314显示了当打开“根据地图比例尺的大小动态调整屏幕显示内容”选项时显示的地面填图数据文件。与之相对,当关闭此选项时的显示结果如图71(第69页)所示。由此可见,当启用动态内容显示时可以明显改善数据的可视性能。

 

314:当打开“根据地图比例尺的大小动态调整屏幕显示内容”选项时显示的地面填图数据文件。

 

3.8.3    绘制曲线预览功能

MeteoExplorer支持用户以交互的方式绘制各种几何形状和符号。当用户绘制曲线时,一般通过绘制若干控制点(或称为锚点,anchor point)来确定曲线的形状。在实现上,程序通过将这些用户绘制的控制点运用样条理论进行平滑处理,计算得到对应的曲线。

MeteoExplorer支持在用户绘制曲线的同时将样条平滑的结果实时地显示出来。我们将这一功能称为预览。要打开预览功能,请选择“Smooth linestrip when drawing synoptic chart”。图315显示了打开绘制曲线预览功能时曲线的显示结果;图316显示了关闭绘制曲线预览功能时曲线的显示结果。关于用户交互绘制图形的详细说明请参考15

 

315:打开绘制曲线预览功能时曲线的显示结果。

 

316:关闭绘制曲线预览功能时曲线的显示结果。

 

3.8.4    中英文用户界面语言快速切换

MeteoExplorer提供了英文和简体中文两套用户界面语言,并且在这两种语言之间快速切换的功能[2]MeteoExplorer会在启动的时候自动检测用户系统的语言设置。如果系统语言是简体中文,那么MeteoExplorer会使用简体中文作为用户界面语言;对于其它语言,MeteoExplorer会使用英文作为用户界面语言。

用户可以通过用户偏好设置对话框(图311)中的“UI Language”分组框的单选按钮“English”和“Simplified Chinese”在两种语言之间切换。图3‑17显示了中文界面下的用户偏好设置对话框(图311)。

 

317中文界面下的用户偏好设置对话框。

 


第4章     地图与地理信息功能

MeteoExplorer提供了基本的地图信息功能,本章将详细介绍这些功能的使用。

4.1     地图投影参数的设置

MeteoExplorer支持多种投影方式,包括兰伯特投影(Lambert)、麦卡托投影(Mercator)、北半球投影(North hemisphere)、南半球投影(South hemisphere)、等距离投影(Equal distance)、等面积投影(equal area)、和正交投影(Orthographic)。其中兰伯特投影还需要指定投影中心点的坐标位置。

要设置投影参数,请选择菜单项“OptionProjection and Map”,打开“Projection and Map”对话框(图41)。在“Projection Type”下拉组合框中选择投影类型;在“Projection Longitude”和“Projection Latitude”编辑控件中选择投影中心点的坐标位置的经度值和纬度值。

 

41MeteoExplorer的“Projection and Map”对话框为用户提供了设置地图和投影参数的选项。

 

在默认配置下,MeteoExplorer的投影方式是兰伯特投影,投影中心点的位置是110E30N。图42显示了把投影中心点的位置改为80W30N后的地图。图43显示了把投影类型转换为麦卡托投影后的地图。

42:投影中心点的位置设置为80W30N时显示的地图。

 

43:投影类型为麦卡托投影时显示的地图。

 

4.2     基本地图功能

4.2.1    主题风格

MeteoExplorer预定义了三种主题风格,分别是:

l  业务主题(Operation)。在业务主题中(图44),背景为黑色,不区分陆地和海洋。由于黑色的对比度明显,因此业务主题适合于显示大量不同类型数据的情况。

44业务主题下背景为黑色,不区分陆地和海洋。适合于显示大量不同类型数据的情况。

 

l  出版主题(Publish)。在出版主题中(图45),背景为白色,不区分陆地和海洋。所有图形均显示为黑色,彩色图像显示为黑白灰度图像。出版主题适合于将窗口内图形输出为图像文件,作为演示或者出版使用。

45:出版主题下背景为白色,不区分陆地和海洋。适合于将窗口内图形输出为图像文件,作为演示或者出版使用。

 

l  现代主题(Modern)。现代主题(图46)是MeteoExplorer的默认主题。现代主题与常用的地图软件(如Bing MapGoogle Map等)相似,海洋为淡蓝色,陆地为米白色。

46:现代主题是MeteoExplorer的默认主题。其中海洋为淡蓝色,陆地为米白色。

 

要在MeteoExplorer中更改主题,请在“Projection and Map”对话框中选择“Theme”下拉组合框中的选项。

4.2.2    地形显示

MeteoExplorer通过颜色的变化显示大陆的地形高度(图47)。

 

47:在MeteoExplorer中显示地形。

 

要在MeteoExplorer中显示地形,请在“Projection and Map”对话框中选中“Show Terrain”。

4.2.3    单省显示与省份填色

单省显示与省份填色是MeteoExplorer 1.2中新增的功能。省份填色默认是关闭的,选中“省份填色”控件将得到如图48所示的结果。要只显示某一个省,请在“单省显示”组合框控件中选择您选择的省份,图49显示了单独显示吉林省的结果。

48:打开省份填色功能后的显示结果。

 

49:单独显示吉林省的结果。

 

4.2.4    在省界内显示所有图形

我们在科研、业务工作中常常需要让图形图像只显示在特定的区域中,如只在国界或者省界内显示。MeteoExplorer在版本1.2.0025中增加了这个功能。打开这一功能的方法是在“地图与投影”对话框中选中“在省界内显示所有图形”控件。图410给出了在国界内显示201272808时全国24小时降水量图。此图中同时显示省会名称,并隐藏了经纬度网格线。

 

410:在国界内显示201272808时全国24小时降水量图。

 

411是在广东省内显示20127312024小时的变温图。

 

411:在广东省内显示20127312024小时变温图。

 

4.2.5    显示南海

如图412所示,在“地图与投影”对话框中选中“显示南海”控件,即可在屏幕左下角的矩形框中显示中国南海区域地图。

 

412:在程序屏幕左下角的矩形框中显示中国南海区域地图。

 


第5章     页面布局及其设置

在天气预报业务和大气科学研究中,用户经常需要对程序窗口中显示的内容进行个性化定制。显示内容通常包括各种图形要素:以图层方式组织的图形对象、标题、图例、插图等。个性化定制即调整图形要素的位置、大小等。这里我们将图形要素在程序窗口中的位置与大小的组织称为页面布局。MeteoExplorer Touch提供了看图模式和出图模式两种布局视图,并给出了“页面布局设置”对话框供用户进行个性化定制。

5.1     页面布局设计

1.2及其以前版本的MeteoExplorer中,程序主窗口中显示图形对象时没有布局的概念。具体来说,就是底图充满整个窗口,一些必要的图形要素(如图例、插图等)或者显示在底图的上方,或者没有地方显示(例如标题)。因此,已有的显示功能无法满足用户出图的需要,开发实现页面布局功能势在必行。

然而,原有的图形显示方式也有其优点,即显示区域面积较大,从而给用户传达的信息量也较大。因此原有的图形显示方式应该予以保留。这样,MeteoExplorer 1.3版本中引入两种布局模式:经典的看图模式和新增的出图模式。图51给出了出图布局模式中主要图形要素位置和大小的设计。

 

51:出图布局模式中主要图形要素位置和大小的设计。

 

在图51所示的设计中,窗口上方为标题区(Title Region),右侧为图例区(Legend Region),中间为画布区(Canvas Region)。画布区左侧和下方分别是纵坐标文字区(Ordinate Text Region)和横坐标文字区(Abscissa Text Region)。各个区域的预设功能为:

l  标题区(Title Region):显示标题。MeteoExplorer允许用户设置主标题和副标题的内容。

l  图例区(Legend Region):显示用来说明某一图形对象显示属性的图例,常见的图例有填色等值线的色斑条,卫星云图和雷达拼图纹理的色斑条,天气图表中的符号说明等。

l  画布区(Canvas Region):显示所有图形图像对象。即将看图模式下显示的内容限制在画布区中。

l  纵坐标文字区(Ordinate Text Region):纵坐标的文字说明。当画布区中显示地图时,通常使用纬线的刻度值作为纵坐标文字。

l  横坐标文字区(Abscissa Text Region):横坐标的文字说明。当画布区中显示地图时,通常使用经线的刻度值作为横坐标文字。

 

需要注意的是,图51所示的设计是MeteoExplorer给出的缺省设计,用户可以根据需要改变以上5个区域的位置和大小。除横坐标文字区和纵坐标文字区通常位于画布区下方和两侧外,任意两个区域之间可以相交或者重合。

5.2     选择页面布局模式

要在MeteoExplorer中改变页面布局,请选择菜单项“视图,布局”,或者点击工具栏中的“布局”按钮。这两种方法都将弹出如图52所示的菜单。

 

52:选择菜单项“视图,布局”,或者点击工具栏中的“布局”按钮,都将打开改变页面布局的菜单。

 

MeteoExplorer中默认的布局模式是看图模式(或称为看图视图),用户可以直接选择“出图视图”菜单项以切换到出图模式。图53给出了出图模式下对应图61268页)的显示结果。

 

53:在出图模式下,所有图层的显示都被局限在画布区中。

 

5.3     从图层信息中获取标题和图例

如图53所示,在出图模式下MeteoExplorer并没有为用户添加标题和图例。但是MeteoExplorer提供了两种添加标题和图例的方法。第一种方法是在“页面布局设置”对话框中输入标题和图例的内容,具体操作步骤请参考第5.4节。第二种方法是从某一图层信息中获取标题和图例。

MeteoExplorer中,每一个图层都有一个对应的标题,显示在图层管理窗口中(如第24页的图38所示)。MeteoExplorer允许用户把某一图层的标题作为页面的标题。方法是在图层管理窗口中用鼠标右键点击图层标题,这就调出了一个上下文菜单(图54),选择“将图层标题设置为页面标题”这一项则将图层的标题设置为页面的主标题。

 

54:在图层管理窗口中用鼠标右键点击图层标题,将会调出了一个上下文菜单。选择相应的菜单项将图层的标题(图例)设置为页面的标题(图例)。

 

         使用同样的方法可以把图层的图例设置为页面的图例。注意到所选择的图层应该包含图例信息。如果所选图层没有图例信息,则设置操作是无效的。图55给出了一个将图层标题和等值线色斑条作为页面标题和图例的例子。

 

55:将图层标题和等值线色斑条作为页面标题和图例的显示结果。

 

使用图层的标题(图例)作为页面的标题(图例)这一方法的好处是当用户对图层进行翻页和动画操作时,程序窗口中的标题和图例随着图层数据的改变而更新。这样用户无需在翻页时手动修改程序窗口中的标题和图例。

5.4     布局设置

在选项菜单中选择“主窗口布局设置”项后,将会打开“布局设置”对话框(图56,图58和图59)。“布局设置”对话框中控件的布局分为三个部分,上半部分是布局设置区,里面的控件供用户用来进行布局设置,下半部分是预览区,里面的矩形用来显示标题区,画布区和图例区的位置与大小。

5.4.1    预览区

如图56所示,在“页面布局设置”对话框的下半部分是预览区。预览区中使用矩形图形表示整个程序窗口页面,标题区,画布区和图例区。在标题设置,画布设置和图例设置这三个项目中,当某一项目作为当前可见项目时,预览区中的代表该项目的矩形的显示属性由无填充变为使用深灰颜色填充。目的是使用明显的视觉信息告诉用户当前正在设置的项目。此外,当用户调整某一区的位置和大小时,代表此区的矩形的位置和大小也会作相应变化。

5.4.2    设置标题

“页面布局设置”对话框上半部分的布局设置区以分页的形式包含标题设置,画布设置和图例设置三个项目。在程序启动后第一次打开“页面布局设置”对话框时,上半部分的布局设置区是标题设置(图56)。这里用户可以通过调整“上边距”和“左边距”的数值改变标题区的位置;通过调整“高度”和“宽度”的数值改变标题区的大小。注意到“上边距”,“左边距”,“高度”和“宽度”数值的单位都是像素。如果您使用图层标题作为页面标题的话,请让控件“使用图层标题作为页面标题”处于选中状态。否则,您可以直接在“主标题”和“副标题”中直接输入标题内容。

 

56:“页面布局设置”对话框上半部分的布局设置区以分页的形式包含标题设置,画布设置和图例设置三个子区。在标题设置区中可以设置标题的位置、大小,和内容。

 

当用户调整标题区的位置和大小时,则预览区中代表标题区的矩形的位置和大小也会作相应变化。

57给出了对应于图55并且增加副标题为“XXXX市气象台”后的显示结果。

 

57:增加副标题为“XXXX市气象台”后的显示结果。

 

5.4.3    设置画布

如上一小节所述,“页面布局设置”对话框上半部分的布局设置区以分页的形式包含标题设置,画布设置和图例设置三个项目,但只有一个项目处于可见状态。用户可以在三个项目之间切换。

在画布设置区中,用户可以设置画布区的位置和大小,横坐标和纵坐标的文字,以及是否使用地图经纬网的刻度值作为坐标轴文字。当用户改变画布区的位置和大小后,预览区中表示画布区的矩形的位置和大小也会随之变化。

58:在画布设置区中,用户可以设置画布区的位置和大小,横坐标和纵坐标的文字,以及是否使用地图经纬网的刻度值作为坐标轴文字。

 

5.4.4    设置图例

在图59所示的图例设置区中,用户可以设置图例区的位置和大小,图例的样式和单位。同样,当用户改变图例区的位置和大小后,预览区中表示图例区的矩形的位置和大小也会随之变化。MeteoExplorer中提供的图例样式有以下五种:

l  水平条状两端直角

l  水平条状两端尖角

l